Maintenance has concluded, we are monitoring over the next 24 hours for any serious failiures.
Posted Mar 23, 2025 - 04:38 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 22, 2025 - 23:00 UTC
Scheduled
After much testing of the RRMN System, full integration will be confucted which will finalise it into a full production environment.
This maintenance will go on for an unknown period of time, though is scheduled for 4 hours. During this time please ignore all status updates from associated services and monitoring partners.